Forum: Wineskin Support Forum

El Capitan Troubleshooting

What I've found so far, which doesn't match up to user reports.

Wineskin is working just fine for me in El Capitan (Fresh install no changes), as long as I'm using the Mac Driver.

I get errors during wrapper creation and on launch about xkbcomp failing to find a dylib. This looks like a mistake on my part on the path its looking for. This always worked on older versions of OSX because it found it in the fallback path. This no longer works because of Apple's changes blanking out the fallback path. I'm going to work to get the paths fixed on many libraries and programs like this in there that are needed. Everywhere I cannot set a fallback path easily, I should be able to fix the actual path so the libraries are still found.

Any comments? others have said the Mac Driver didn't work for them, but I cannot get it to fail. I've tried several Wine versions back into 1.6.


I have a MT4 for trading forex and not work on El Capitan....

This is the error 

An error occurred while starting the X11 server: "Failed to activate core devices."


Click Quit to quit X11. Click Report to see more details or send a report to Apple.



I updated from Yosemite to El Capitan, no clean install. Mac driver would be perfect for me, but none of my apps (every uses the Mac driver) are working. Sometimes nothing happens and sometimes I'll get an empty window. Even quitting the app doesn't work. I have to kill the process.


One of the error in the LastRunWine.log is:

err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng14.14.dylib

That's strange, because libpng14.14.dylib is in Contents/Frameworks.

I just copied libpng14.dylib to /usr/local/lib, but I'm still getting an empty window (but now without an error in the log). At some other apps, there are problems with other libs (I just didn't want to copy every lib).

After that I started a command line wine test and I ran "WINEDEBUG=err wine my.exe"

Some of the output that looks important:

wine: Unhandled page fault on read access to 0x00000070 at address 0x49d5621e (thread 0009), starting debugger...

This looks just more important:

err:syslink:SYSLINK_SetFont Failed to create link font!


Any idea?



If you like I will let you remote into my Mac.

MacDriver does work sometimes to some extent but the windowed content is missing.

FWIW, I really need the WineskinX11 driver.

FWIW-2 There are reports on the XQuartz users mailing list saying some users have no window content either but the admin questions their reports.


And BTW, thanks for getting this wiki working again with Safari and iCab (Firefox GUI, bad).

I've definitly found opening WineskinX11 and all its sub-programs it requires fails because DYLD_FALLBACK_LIBRARY_PATH gets unset... this is painful because its required because I cannot really put these dylibs in multiple locations for everything... and I really don't want to spend weeks figuring out to heavily customize each one good enough to not need it...

Working on some other work-arounds at the moment.  Wrapper bash scripts re-setting the fallback seems to be working.

I've fixed WineskinX11 launching correctly... but when its doing so, Wine doesn't seem to find any libraries correctly now... at least I feel I'm making some progress.

Latest Update:

I have a test wrapper fully functional, but it took a bit of manual work...

When I get time I'll work on a couple code changes to do this properly for different scenarios, and update a few other things in the wrapper, and release a 2.6.1, which should work fine.

I'll try to get it out before the end of the day today if I can.

wineskin winery 2.6.1 will be compatible also with previous OS X as Yosemite and Mavericks, or it will be only for el capitain?!?




I will be willing to test also everyone please remember to donate...



Hi Doh123,

Some of us who believe in a God are praying for your complete success in this effort. It would bless many, many people.

Bless you!

I don't plan on breaking anything... it should work with 10.6 - 10.11.

I have to make wrapper apps to set DYLD_FALLBACK_LIBRARY_PATH for everything needed for WineskinX11 and Wine.  I have to modify WineskinLauncher to pass the correct path info (which is different depending on options) to the wrapper apps in some vairable other than DYLD_FALLBACK_LIBRARY_PATH since Apple blanks it out... then set it specifically for each program that gets called.

Its basically broken because in 10.10 and before, when I exported that variable, it stuck for all processes spawned from the parent process.  Now that variable blanks out every single time, which breaks everything.


Hopefully I can get it done here soon before Church tonight  :-) And thanks for the prayers

I added a new post about Wineskin 2.6.1 link)

Hmm im not finding anywheres to download it


It should be listed as an update in Winery.


I have a custom engine and have updated the wrapper to 2.6.1, what do I need to do to make the engine compatible with 2.6.1?


How does one update a wrapper w/o having to remake it?  I see nothing about it in the Manual.  Can you post instruction, please?

Yes I saw it. Thanks for everything. I been tring to get check boxes to show up that's on a tab. You wouldnt know anything about that would you

Andrew:  I'm not sure how the engine was made... just put in a fresh copy?  If you rename your wrapper it could also force an engine update.  Basically there are wrapper scripts for wine and wineserver that are made.  The new ones have to set an extra variable.  Wineskin will not try to re-create these if they already exist.  It'll fix them right the first time an engine is used.  If I remember right, it does base it off wrapper name, so it can kick off an update to those wrapper scripts if the wrapper has a different name.

Henry84:  There is an Update Wrapper button in Wineskin Advanced on the Tools tab.  This will update an older wrapper to a newer one, so you can update to 2.6.1 without having to rebuild the wrapper from scratch.

Archonis:  I don't know what type of checkboxes or tabs you are talking about...

thanks you very much, it is working great for me now! just thank you for Wineskin, i know there is alternatives (playonmac,etc..) but wineskin has been  just perfect for me.. the possibility to use 2 little softwares that i used for years when on Windows (became dependant of this 2)  now on OSX without going bootcamp, virtual machines, parallels.... THANKS!



Great, thank you, I got it to work!

Page: 1/3

The original document is available at