Loading...
 

Wineskin Support Forum Help

Forums » Wineskin Support Forum » SWTOR strange issue

SWTOR strange issue

Hi doh
here's Thelothian :-)

Today I've launched SWTOR to apply some small patches required. After that I noticed that the LAUNCHER, take the 100% cpu for no reason whatsoever, slowing down the entire system. This happens right after you press the LOGIN button. Is it normal? Perhaps because the launcher continues to look for the server connection... otherwise it can be a small bug.

Tomorrow the testing week-end will start and I'll be able to check the overall performance.
Finger crossed...



A few days ago I could actually get to character selection. However since the start of this week there have now been two new patches. As soon as I hit PLAY from the launcher, my CPU use is at 100%, the temp hits 90 degress and my fans go like crazy but the game never actually launches now.

Not really sure what I can change to get it to work, but good luck getting it working at the weekend Doh!



My launcher isn't pulling but maybe 50% while patching... then about 18% at idle... I cannot hit Play yet as the Beta test weekend still has like an hour to start... and I'm leaving before that out of town for the day to visit some friends.  Hopefully I can test it some tonight, but I haven't seen this issue.  When the actual game is running, I except high CPU usage though, but it should be pretty low during patching.



The launcher patched succesfull. But after hitting PLAY, CPU goes 100% and nothing happens... after 2-3 mins all system becomes unresponsive. I've to force reboot with power button. Don't understand why... have you any idea?



I don't get 100%, but its getting stuck.  last beta update looks like it added a new problem and the game is currently not playable at all with Wine.



What luck! Right now the beta weekend has begun. I have a feeling that we'll not be able to see this game in time.
The fact that Mac users are forced to do these things, it makes me even more angry. BioWare sucks. 

Is there a way to have a detailed log from Wine, just to understand why it crashes? I've tried TEST MODE, but not helpful ... 

BTW, next week will be released the patch 4.3 of WoW. Good reason to forget about this MMORPG. ;)



You'd need to look up Wine debug channels at winehq.org and you can set up which ones the Test Run button uses on the Advanced Config tab... then get more detailed logs.

Right now no one I can see has gotten the new update to let you log in right under Wine.

That said, I did run the game in Win7 under Parallels and it ran suprisingly good for a VM.



Tried under Parallels... Very good at high resolution with higher settings!!!! Really surprisingly... Until now we can play it on a Mac.



I'd add a "me too" comment here. Installing, downloading/patching the SWTOR launcher caused no issues. The only thing I noticed was that the launcher window would turn completely black if I started to move it around on the screen. This behaviour was consistent. The solution every time was to restart the app. Another solution was to keep my hands off the window, not to move it around any more.

Once I hit the play button, the real issue starts... The Wine process eats between 93% and 99% of my CPUs. I have eight of them, so effectively Wine uses almost 800% of my CPUs. This locks down my Mac completely, and the only workaround is to reboot the machine.

So I've not been able to get this to run at all (it runs superb on my Windows 7 partition though).

FYI, system specs are as follows: Mac Pro 2.8 GHz (8 cores), ATI Radeon HD 5870, OS X 10.7.2, and the latest Wineskin wrapper/engine.

I'll have a peek on Portingteam.com, but the beta is already over for my part, as I have work to do from now on and thus cannot test any further.

Keeping high spirits though: Even if a patch might have broken Wine compatibility now, it used to work (as demonstrated by others), so it'll work again. I'll do some thorough testing once I get into the headstart before official launch. Patience, young padawans...



All this is not urgent, because I personally found the game very nice but not enough to justify an effort to make it run under Mac .. Right now I'm waiting for the WoW 4.3 patch. I certainly never bought a game or will sign a subscription to use a client under emulation /wineskin. If BioWare wants my subscription, I demand a REAL version for my computer.

No excuses...


Post new message

Attach file Maximum size: 10.00 Mb
Post new reply

Show posts: