Loading...
 

Wineskin Support Forum Help

Forums » Wineskin Support Forum » Downloaded wrappers not working on macOS Sierra

Downloaded wrappers not working on macOS Sierra

Hi!

We have an wrapper that has been used for years, sadly it doesn't work on Sierra anymore.

What happens is that nothing happens, you start it up and nothing is showing.

I tried to create a new wrapper with exactly the same settings and engine and it worked fine. But once I upload it to our server and someone downloads it on a different mac it will not work anymore (Same problem as described above).


Is it not possible anymore to share self created wrappers?



You can try to create a WSI file of the wrapper and install it in each machine using the Porting Kit. It will consume a smaller amount of space in the server and probably will solve your problem, which is most probably related with macOS security restrictions.



I found a solution...

It seems like the downloaded wrappers can't be started directly from the downloads folder anymore. You have to move them into the Applications folder first.

A new security feature?

 

The good old .zip wrapper times are over, oh noes!

I'm now using a .dmg file to share my app, works fine.

 

I have a feeling this bug can be fixed though, hope you guys can look into it at some point (I hate .dmg files, people are not understanding it)



Strange that moving them to a different folder worked. About the security feature: since Yosemite (or Mavericks, I can't remember now), Wineskin wrappers are considered untrustful apps when moved to a different computer because they aren't signed. You have to right click them and press Open. 

There was another problem in El Capitan where wrappers needed to be updated to work, but I don't know about Sierra, so I guessed it could be a new security feature that was interfering with downloaded wrappers again.

Did you found a way to sign your Wineskin wrapper?

 



Thanks for the info, it worked again if I placed the wrapped app in the Application folder or user's Application folder before the first run with right-click-open!

Same trouble happened on freshly clean installed Sierra (Japanese ver), though it ran if it's installed before upgrading the OS to Sierra.

I bought a new Sierra pre-installed MacBook and was struggling with this problem. Thanks.

 

 

 



@VitorMM

Yes I know the portingkit, I really like it a lot. I have it in my to do list, still have to look up how the wsi files work and get it done.

It's still the same on sierra, you have to right click and open. They also removed the feature where you could set it up to just open them instantly, but that's not a big deal though.

I didn't look into signing yet, I was under the impression that it's not free, so I didn't really care about it yet. Is there a way to get it done for free?

 

@KEINOS

Great to hear you got it working too!

 

 



@WSkinUser12

Signing requires an Apple Developer account (which is not free), so no, unfortunately there is no way to sign without an Apple Developer account. 



This is an issue with App Translocation introduced in Sierra.

You can read more about it here:

http://lapcatsoftware.com/articles/app-translocation.html

You can still distribute with zip files, you just need to tell the user that after they unzip the app, they need to move it to a different folder. 



Taken from the above link:

 

"Under what circumstances does App Translocation occur? First, the app must have a com.apple.quarantine extended attribute. If you delete the quarantine xattr, then App Translocation does not occur, and the app will launch from where it was unarchived"

 

 

 



Under what circumstances does App Translocation occur? First, the app must have a com.apple.quarantine extended attribute. If you delete the quarantine xattr, then App Translocation does not occur, and the app will launch from where it was unarchived, like normal. Second, the app must be opened by Launch Services. This usually means Finder, but it can also mean open from Terminal, for example. If you launch the app executable directly from bash, on the other hand, App Translocation does not occur. Third, the app must not have been moved — by Finder. If you move the app, using Finder, from the app's original unarchived location to another folder, even a subfolder, e.g., ~/Downloads/Test/, then App Translocation does not occur. However, if you move the app using mv from Terminal, then App Translocation will still occur. Normally you would move the app from ~/Downloads to /Applications, and that would cause the app to be launched from /Applications like normal, but the locations of the particular folders don't seem to matter. The mere act of moving the app using Finder stops App Translocation from happening. Indeed, once you've moved the app once, it will no longer experience App Translocation again, even if you then move it back to ~/Downloads.


Post new message

Attach file Maximum size: 10.00 Mb
Post new reply

Show posts: