Wineskin Support Forum Help

Forums » Wineskin Support Forum » Dishonored - Main Game Works But DLC Hangs

Dishonored - Main Game Works But DLC Hangs

I've gotten Dishonored (purchased via Steam) working in a Wineskin 2.6.2 wrapper with the WS9WineCX14.1.10 engine on my iMac with a Radeon 4850 running OS X 10.10.5. (It does not work with any of the more standard Wine versions I've tried, up to 1.8-rc3 and 1.7.55.)

I've played through the main campaign successfully from start to finish without any issues. Since it was working and I enjoyed the game, I purchased both of the DLC (Knife of Dunwall + Brigmore Witches) during a recent Steam sale.

Neither DLC makes it past the loading screen. I don't see anything in the Wine logs (outside the typical, usually-inconsequential Steam-related warnings and errors, which are there for both the main game and the DLC). On the other hand, I don't see anyone reporting this issue in trying to run the game under Windows. I'm left scratching my head as to whether this is a bug in the game itself or something the DLC does just a little differently that's making it fail under Wine. (Note that the main campaign works just fine with or without the DLC--nothing changed there.)

Has anyone tried this and managed to get the DLC working?

As an aside, if anyone is interested in running just the main campaign, it runs essentially perfectly in my setup. The only issue is that the first few seconds after a level load stutter, before the framerate stabilizes. If I had to guess, I'd guess it would have that same stutter in Windows.

Strange. Usually when the main game works the DLCs/expansions work too. Have you tried to use WineskinX11 if you are using MacDriver or the opposite? 

The game works identically either way.  The campaign works fine, but the two main expansions hang at the loading screen.  For those familiar with the game, you get a loading screen with some text, and a blinking Loading indicator in the bottom right.  For these two DLC, the indicator blinks twice, then stops and the game hangs.  I've let it sit there for 20+ minutes, just in case something has really slowed down.  Oddly, the mini-DLC (Dunwall City Trials) loads fine.  I've not actually played it yet, but it gets past the loading screen where the other two fail.

It is a weird failure mode.  I've gotten probably 50 or more Wineskin wrappers working for games, and I can usually figure out what's wrong, but there's exactly nothing in the logs that's different between running the main campaign and trying to load the DLC.  The one works and the other just doesn't.





Dishonored DLC still don't load. Has anyone resolved this?

It works with latest Wine Staging 20.


Post new message

Attach file Maximum size: 10.00 Mb
Post new reply

Show posts: