Wineskin Support Forum Help

Forums » Wineskin Support Forum » The Witcher 2

The Witcher 2

First, thank you very much for your response to my earlier request for help. I have installed vcrun2008 and vcrun2010. I have tried disabling and enabling glsl. I have tried setting resolution to 1280x1024. My native resolution is 2560x1440. I have run The Witcher 2's Configurator.exe and set the resolution to match WINECfg. I have also tried WINECfg configured for full screen and The Witcher 2 configured for full screen. However, The Witcher 2 still will not launch. Attached is the LastRunX11.log. Thanks for any advice.

I did notice some people on the AppDB had installed some of the Direct X 9 dll files as well... one of those might be needed?

Setting a virtual desktop and resolution in winecfg isn't the best way to do things in Wineskin. You are much better off using the Set Screen Options button in Wineskin.app and setting up things there. If you do have it on automatic, then winecfg options should work, but they may not work at all if that is set to override.

X11 is running fine... you need the Wine log file to see what problems Wine is actually having. You can copy and paste logs if needed, or use a website like pastebin.com and put the links here if they are really large.

So I followed your suggestions. I created a new wrapper and installed d3dx9, d3dx10, d3dx11_XX, vcrun2005, vcrun2008, vcrun2010, and corefonts. Still does not run. The WINE debug file just has a fixme and that is it. The only thing I did with WINEcfg was change from XP to 7. Any advice is greatly appreciated. Thanks.

Wine barely supports directx10 and directx11... I'd suggest not even installing any of those for normal use of a dx9 title.... and any game you play that supports DX9 or DX10/11 you pretty much need to run the DX9 version. While DX10/11 is being worked on its not really yet too useful for running games. I'm not sure you need all those vcrun versions either... basically you never install anything unless it is really really needed, because installing some extra things can sometimes break other things.

What is the fixme? Does the game have multiple exe files it can run and are you running the right one?

I'm not sure what to say beyond that since I've never run the game... its supposed to work ok...

I created a new wrapper and only installed d3dx9, vcrun2010, corefonts. The game has Launcher.exe, Configurator.exe, and Activiate.exe. The game has to be launched using the Launcher.exe (even to activate the game). Executing Configurator.exe does run the graphics configurator. Executing Activate.exe opens a message box stating to activate using Launcher.exe. The LastRunWine.log output is: fixme:heap:HeapSetInformation 0x0 1 0x0 0. The following link is the games WINE AppDB entry. I've tried following the sequence it suggests with no luck. Thanks in advance. http://appdb.winehq.org/objectManager.php?sClass=version&iId=23504&iTestingId=64212(external link)

Changed the display using Wineskin Display Setting UI. Launching game goes into full screen mode for a few second and then closes. While in fullscreen, blackscreen. I have attached the LastRunX11.log and LastRunWine.log in the next post. Thanks in advance.


are you sure its running the right exe file? is it a no-cd hacked exe?

it looks like its not trying to do anything.

trace:x11settings can always be ignored.. they only show up if your using Override->Fullscreen, as Wineskin is handling things manually that way and needs the log data to figure out what is going on.

What Mac are you running this on... mainly what GPU?

Its also easier if you copy and paste the text of the logs directly in here, or on pastebin.com and link it here... rather than having to attach a PDF file.

I bought a full retail copy of The Witcher 2. Interestingly, I don't have to have the DVD in my drive to play the game. The game is installed in a Bootcamped install of Windows 7 (also a full retail purchase); however since the AMD driver is almost a year old, I want to benchmark the game in the compatibility mode WINE provides. Also, it would just be cool. The GPU is AMD 6970M 2GB.

when you say its installed in a Bootcamped install of Windows 7... do you mean you are actually trying to run it from there? Can be problematic trying to run off a NTFS partition, plus if you didn't install it in Wineskin, you may be missing some registry entires it makes during the install.

I have the game installed on my Windows partition; however, I also wrapped a seperate install in a WINESkin wrapper. Other wrappers I've created seem to work fine. Neverball wrapper is working and the Steam wrapper seems to be working too. I also tried an earlier build of WINE with the wrapper.

Post new message

Attach file Maximum size: 10.00 Mb
Post new reply

Show posts: