Loading...
 

Wineskin Support Forum Help

Forums » Wineskin Support Forum » .app works in Test Mode but not regularly

.app works in Test Mode but not regularly

I made a wrapper for the newest version of foobar2000.

When I test the .app in Test Mode is works perfectly but when I click it in Finder it fails to launch with the error code -10810.

In Console I see this error message: "spawn_via_launchd() failed, errno=22 label=foobar2000482645427Wine.winskin.prefs.28896 path=/Users/xxxxxxxxxx/Applications/Wineskin/foobar2000.app/Contents/Mac OS/WineskinLauncher flags=1

I don't have Gecko or Mono installed and I'm using OS X 10.9.

If anyone knows what's up I'd really appreciate it!



I've heard of people occasionally having problems with WineskinLauncher like that... the issue is I cannot reproduce it and cannot figure out why it would happen.  might be something specific to your machine, some setting, program, or who knows what else...  Test run bypasses WineskinLauncher, because its totally not needed at that point since Wineskin.app is acting as the launcher.  The launcher passes control over to the main Wineskin program in Contents/Frameworks/bin and it handles running everything, including the wrapper itself is relaunched as a different X11 app (if X11 is enabled) using WineskinX11.



I think I got a workaround (I don't know if this is the solution)

After creating a blank wrapper, in launchctl remains a loaded process (say: MyCoolWrapper505863260Wine.wineskin.prefs.138720)

 

If you remove it with

launchctl remove MyCoolWrapper505863260Wine.wineskin.prefs.138720

all goes fine. See also: http://wineskin.urgesoftware.com/tiki-view_forum_thread.php?comments_parentId=4665&topics_offset=3(external link)

 



Interesting workaround.  I did some experimenting with it and discovered that something with launchctl is hanging after the creation of a blank wrapper.  I'm not sure if it's something in the OS causing problems or something in the wrapper creation that is getting stuck.

 

To verify this all I did was create a blank wrapper called test.app.  After the wrapper was creation I did a 'launchctl list | grep wineskin' and I get this:

- 0 test250719126Wine.wineskin.prefs.107392

 

Using launchctl remove works fine.  I just have to make sure to do that after creating a wrapper.  Thanks for that tip.

 



Hm, I tried the workaround and now instead of giving error -10810, running my SteamWine.app (which is a wrapper for Steam) launches the WineSkin app which is contained inside it. I still have to run the actual contents via the "test run" button.

 



Hey it's me, the original poster.

Unfortunately I can't help you Peter, but I just wanted to let anyone else who might be reading this thread that I got my application to work after simply restarting my computer. I feel like such a moron!

 

The information maiux provided really helped me. Restarting my computer was just another way to quit that pesky process.

 

Thanks for all the help everyone! Peter I hope your issue is resolved soon D; sorry I can't do anything to help; I've only used wine for foobar2000 so I know nothing about the intricacies of making wrappers

 



Just a quick "me too."  I was following some instructions for building a Terraria wrapper and had the same problem with a stray launchd job.  Removing it solved the problem.  It'd be great to have a fix for this, since aside from that most everything worked flawlessly.

Thanks!

 



Same here: I just posted a new note before I saw this, but following the instructions to remove the launchctl job fixed it. 


Post new message

Attach file Maximum size: 10.00 Mb
Post new reply

Show posts: