Wineskin Support Forum Help

Forums » Wineskin Support Forum » ie8 in wineskin

ie8 in wineskin

Hi there,

I have a Wineskin app which uses an Explorer view of some sort and which has stopped working properly with recent versions of Wine. In trying to solve the issue, I attempted to install ie8 via WineTricks, a process which simply fails in Wineskin (the download occurs, but then all sorts of errors appear (windows dialogs and also errors in the log)). I tried WineBottler and can create a prefix there, adding ie8 vie WineTricks without any trouble, and run the app properly. However, I really prefer Wineskin to WineBottler and I'm aesthetically opposed to keeping both around. :-) Nor do I want to convert my other Wineskin apps to WB, so...

Any idea what the problem is? I'm on OSX 10.8.4 (64-bit, German main language). In looking around, I've seen some people complaining about similar problems on 64-bit Linux, where Wine can't reconcile the 64-bit OS with the 32-bit Wine. But maybe someone here has some idea.


Wineskin wine engines and prefixes are all 32 bit.  Wine doesn't really handle 64 bit on OS X right at all.

If you updated Winetricks to the latest and it still doesn't work... I'm not really sure.  Sometimes certain Wine versions and Winetricks version combinations work best.  Winetricks is generally made for the latest Wine version, so if you update Winetricks, you may want to use the latest Wine version as well, even if you want to downgrade the engine later on... you don't need to use the same engine for everything.

I'm surprised IE8 is installing though, last I tried even with command line plain Wine and Winetricks it didn't work.

It works fine with vanilla wine, WineBottler and CrossOver. I just installed wine and winetricks via homebrew and everything is working _great_, in fact. In Wineskin, I can't even update winetricks without hanging the interface (it just goes into a progress bar coma). Although I find the self-containedness of Wineskin pretty cool and, if I needed to push apps around from machine to machine, really practical, it uses 300MB per app no matter what and seems to be suffering from some incompatibilities which aren't present in other Wine variants. Alas.

Now that I know that it's possible, though, homebrew-wine + Platypus does what I need for now.

I know updating Winetricks in Wineskin takes a long time... a very long time.  This is because its coded to run Winetricks in order to get info from it to build out all the available info it needs to populate the GUI... it has to run it multiple times with different options, and Winetricks is very slow doing this.

Someone already wrote some code and gave it to me to pull all this info directly fromthe text script and not run Winetricks, which should make the updating very very fast... as soon as I can get it in and tested for Wineskin 2.5.10, which I really hope to get done in the next few weeks.

The reason its failing is because the application iexplorer for wineskin is installed and represented as IE8 which it will not install over it. You will need to remove all files, registry entries and try the installer again, I had this issue as well.


Reply to the selected post

Attach file Maximum size: 10.00 Mb
Post new reply

Show posts: