Loading...
 

Wineskin Support Forum Help

Forums » Wineskin Support Forum » Printing from a wineskin wrapped program

Printing from a wineskin wrapped program

I've been looking to an alternative to firing up parallels just to run a very simple exercise application that is windows only. I use it to print out exercises for patients of mine at my office.

I have successfully created a wrapper and the application runs great, but hangs when I attempt to print off the exercises. The program is called Phases Rehab. I click the print button, and instead of being prompted to choose a printer etc, it just sits there and nothing happens.

I saw that printing should work unless the application is attempting to use windows only drivers. Can someone instruct me on how to figure out if this is the case? Or is there something I can change in the settings to get it to prompt the normal OSX print window? Thanks!

I tried looking at the log files, but seems to be all font errors or something. I would attach the log file but it's 44mb plain text and 14mb as a pdf.

The end of it is just repeating lines of:

fixme:richedit:ME_HandleMessage EM_FORMATRANGE: stub



the best thing to do with log files... copy and paste them over at pastebin.com, and then just paste a link to them here.

As to why its freezing... I really don't know as most printing works fine with no changes needed, and this isn't something I've had to troubleshoot much.  Seeing what its complaining about when its actually trying to print may help.



Ok, I tried out pastebin but the LastRunWine.log is too large to paste there unless you have a PRO account.

Here's the link to LastRunX11.log: http://pastebin.com/nenkcCG8

I exported LastRunWine to pdf and uploaded to my mediafire account here:

http://www.mediafire.com/view/?v3q7dc0amsd5rrp

 

Thanks doh123 for any assistance you can provide! 



not much useful in there but a bunch of stubbed info...

Not really seeing why it doesn't work, but being that there are TONs of abnormal Fonts trying to be loaded that its having problems with, it might be related to Font issues.

Being as they only support Windows XP... it might be a problematic program no matter what you try.  According to their website they are in the process of making newer versions including a Mac version.

I'm not really sure what to tell you to try at this point... there's very little info around the web on that peice of software.



Ok, thanks for looking into it and the quick response. I'll just have to continue booting parallels for now and fork over cash for the mac version if it ever becomes available.

One thing I will note, if I don't close out of the app quickly it will continue to generate that last statement in the log over and over and over. The first time I tried to copy/paste the log into pastebin, it slowed my system down so bad I had to reboot. When I tried converting that file to a pdf, it was over 4,000 pages long before I cancelled it. The log I linked to, I purposely tried to close it down as soon as I hit print.

It's too bad though, because it is a very simple program and seems to function great with wineskin. But...it doesn't serve it's purpose if I can't print out handouts.

Thanks again, I appreciate your work!

 



This isn't too abnormal for logs.  It is why logs are disabled from even being made at all by default.  Sadly there is nothing much in them to point out the issue to me, but I'm far from a printing expert.  Being that it was hitting Stubs a lot, it is possible its just trying to do things not implemented fully yet in Wine which could be causing an issue.

There are still a lot of known issues with printing with Wine right now...

http://wiki.winehq.org/Printing(external link) 


Post new message

Attach file Maximum size: 10.00 Mb
Post new reply

Show posts: