Loading...
 

Wineskin Support Forum Help

Forums » Wineskin Support Forum » Tron 2.0

Tron 2.0


I just installed Tron 2.0 into wineskin 2.5.8 running OSX 10.8.2. Everything works great except for the mouse movement while playing the game. Oddly enough the mouse works great when navigating the menus. However when the game is being played, mouse movement is choppy and completely unplayable. I've tried about 10 different engines and with some the mouse works left/down only but I haven't found an engine that works. Does anyone have any suggestions or know of a working engine? Thank you!



in some games the mouse can be problematic... I know nothing about that game though so you'll just need to search for common mouse fixes for Wine, and what may be in the AppDB entry for that game.



I'm experiencing the same problem. Tron 2.0 installs and works, except the mouse stutters and lags and isn't usable.



Ok, I think I've narrowed down the problem... It appears the issue only arises when the keyboard is pressed while moving the mouse... i.e. it appears they are on the same channel and the keyboard disrupts the mouse signals. Is there a way to have Cider or even Wineskin use two different channels for the input devices so they don't interfere with one another? Or do you have any other ideas how I may resolve this issue? Looks like someone has detected this too...http://bugs.winehq.o...ug.cgi?id=23016 http://osdir.com/ml/...6/msg00404.html



EDIT: 

I stand corrected, I'm still encountering mouse "look around" issues regardless if the mouse and keyboard are used together.



Hello,

I have been attempting to port TRON 2.0 over to MAC using the CD I had from when the game first came out. I followed the instructions on this blog: 

http://camendesign.com/blog/wineskin_guide#tron20 and installed the software as well as the Unofficial Patch 1.024c. When I ran the converted game for the first time, I was presented with this error in the loading screen.

“The program lithtech.exe has encountered a serious problem and needs to close. We are sorry for the inconvenience.

This can be caused by a problem in the program or a deficiency in Wine. You might want to check for compatibility.”

Does anyone have troubleshooting tips for this error?

I am running on:

OS X El Capitan
Version 10.11.2

MacBookPro (13-inch, Mid 2012)
Processor 2.5 GHz Intel Core i5
4GB 1600 MHz DDR3

Using:

Wrapper Version: Wineskin 2.6.2
Engine: WS8WineCXG10.3.0

I have attached a .log file of my unsuccessful run of the game.


Post new message

Attach file Maximum size: 10.00 Mb
Post new reply

Show posts: