Wineskin Support Forum Help

Forums » Wineskin Support Forum » LotR: BFME II Stuck

LotR: BFME II Stuck

First post:

I'm on Snow Leopard 10.6.7, and have an NVIDIA GeForce 320M. MacBook. On WineSkin 2.4, drivers are the latest one and 1.3.12 and 1.3.27.

I'm trying to install the game via WineSkin, but the problem is..... it has 6 installer discs. I can't eject while its installing, Wineskin says, so I can never go beyond the first disc. So how can I install this? I have AnytoISO, if that might help.

Also for patching this game if ever it is installed, how will I patch it? Download? Will I wineskin the patches too?

Or how about installing the expansion? How can I do that?


Second post:

I was able to install The Battle for Middle-Earth 2 on wineskin...

But its stuck on the loading start screen. Help please! Should I redo installation?
Since there were multiple CD's, I used AnytoISO on the other 5, and when that was done, installed as normal with the first. it worked.

So when it was finished, I selected the bfme2.exe file to run it.

now, it starts up fine, but just gets stuck at the load screen at the start.

I'm using wine ver. 2.4, and using the driver 1.3.12. I have the latest one too (as of posting this forum topic)

Did I do anything wrong? Should I reinstall? help please!

I also need a CD to play it, so I was wondering if there was a patch/crack for no CD playing. if so, where can I find/how do I DL and install the patch?

If making ISOs doesn't work... you can make a custom EXE launcher that runs eject.exe and double click it while trying to install and it will usually force the CD to be able to eject and Wine to see the next one right.

For the starting up issue.. you might need to do some research in the entires for the game in the AppDB
http://appdb.winehq.org/objectManager.php?sClass=application&iId=4372(external link)
I'm not familiar with the specific game so I'm not sure whats needed and what isn't. If its graphical issues, its sometimes helpful to try in Wineskin.app to set the screen settings to override and try fullscreen or a virtual desktop. There are also a lot of DirectX registry entires that can be play around with... most can be set in Winetricks, entered near the bottom of the list, or you can look for what options are available on the following link.
http://wiki.winehq.org/UsefulRegistryKeys(external link)

No CD patches are usually pretty easy to find on the internet.

I'm not really familiar with creating custom exe's, or winetricks. If it would be possible, maybe a full explanation please? I'm a relative newbie here, so I apologize haha.

How do you create a virtual desktop?
Winetricks help? How do you use it?
Or how to change the Direct X?
Create exe?
Graphics are ok (i think)

Maybe someone who already ported BFME II or is familiar with it may help, please. :-D

In Wineskin you can set a virtual desktop in the normal Screen Settings location in Wineskin.app. A virtual desktop is basically a single window that the game will see as its monitor, and think its in fullscreen, but its really in a Window. Make sure you also select to Decorate windows in the same area if you want that window to be movable.
http://wineskin.doh123.com/tiki-index.php?page=Manual+4.2+Screen+Options(external link)

Winetricks... if there is some certain program you need installed... or a settings, or a dll from Windows, or whatever... Winetricks is a quick way to get things done. You do not use it for anything at all unless it actually has something you need. Like many games Fonts will be messed up and installing CoreFonts with Winetricks can fix that... as it installs some fonts for you. You read through the list to see what each option does, then you can select that option to run if its something you need.
http://wineskin.doh123.com/tiki-index.php?page=Manual+4.5+Advanced+-+Tools(external link)

You do not change DirectX. DirectX support is already built in. Sometimes certain functions in the built in Wine version of DirectX will not work right, and sometimes you need to install MS DirectX... but that usually breaks more things than it fixes. Sometimes you just need a dll or two from MS DirectX and not the whole thing... all of this can be done with Winetricks easily.

A custom exe launcher is just another app launcher to run a different exe in the same wrapper, instead of the main exe. This is mainly used like if some game has a setup.exe and a game.exe... you'd set the main game one as the main exe, but occasionally you'd want to run the setup to configure something.
http://wineskin.doh123.com/tiki-index.php?page=Manual+4.5+Advanced+-+Tools(external link)

Well, I tried it, and it pretty much ends up getting stuck like this. :-(

Tried making custom EXE's, even doubling the one for the main game, and one for internet explorer.... no luck. :-(
Can't really put my finger on what is wrong, or what's needed.
Do I need to reinstall?

Tried making custom EXE's, even doubling the one for the main game, and one for internet explorer.... no luck. :-(
Can't really put my finger on what is wrong, or what's needed.
Do I need to reinstall?

It always ends up like this, even after changing the driver.

Gecko.... maybe its a gecko problem?
Gecko somehow ceases to install every time it reaches halfway in the downloader....... is that a problem?

I really do not know... its not a game I ever played, and each game is a case by case basis, with its own issues and fixes. If you research around the web, and mainly in the AppDB and find out what other people have done with Wine to get it to work... and replicate that in Wineskin, and it still doesn't work, then I'm not sure what to tell you at this point.

I'm not sure what the exe launchers were going to do for you, they are just ways to launch different exe files quickly.

Gecko is to replace IE for mshtml web rendering. If the game is using that, it could be a problem... if its not using mshtml, then no its not a problem and you do not even need to install it, it just wastes space.

Someone made a really old version Wineskin wrapper for this before that worked...
http://forum.portingteam.com/viewtopic.php?f=47&t=4387&hilit=middle+earth(external link)
you maybe be able to check that one. It said it needs to be updated to 1.06 and have a no-disc hack put on it to work.

If that one works, you can try updating it to a more current build of Wineskin
http://wineskin.doh123.com/tiki-index.php?page=Can+I+convert+other+wrapper+types+to+Wineskin+wrappers(external link)

Thank you! I'll see what I can do from there, then keep you posted.
I hope I didn't sound to spammy.
Thanks for your patience, and thank you for your help thus far!

Anyhow, I ran a debug and test run, and these were what I got

  • Note I reinstalled the game, updated the gecko, etc.

Mostly incompatible, so I don't know... :-(

Post new message

Attach file Maximum size: 10.00 Mb
Post new reply

Show posts: