Loading...
 

Wineskin Support Forum Help

Forums » Wineskin Support Forum » Font antialiasing

Font antialiasing

I seem to fail at getting font aliasing to work. Tried the registry settings and the winetricks script (which obviously just does the same) but it doesn't seem to work in foobar2000. Any ideas?


Its always seemed to work fine for me... maybe something with foobar?

Do you have extra Fonts installed (CoreFonts or AllFonts...) are all Fonts not doing it, or just certain ones?



AllFonts and Corefonts are installed. I highly doubt it's sth. with foobar. I'm using Wineskin 2.5.3 and wine 1.3.37. I'm probably doing sth stupid but I just can't find out what.



Does the app have any fonts that are at larger sizes, and is it only the larger sized text that gets antialiased?

If so then that's probably due to a quirk in how Wine seems to handle fonts - I guess there is a little bit of information in TrueType fonts that marks a certain size below which to turn off smoothing. Regular Windows seems to ignore that but Wine's font handling actually pays attention to that flag and so decides to turn off smoothing for that font if the font size is below that marked point.

So you may be running into that - I don't think there's any setting to make Wine ignore that font flag, so in order to change that you would need to modify Wine and make a custom build.

I'm not sure if that's the thing that you're running into or not though.

     - Michael

 



I'm having a similar problem with Wineskin 2.5.4 (final) and various versions of Wine (1.4rc4 down to 1.2.3) on Lion 10.7.3.

I just can't get font anti-aliasing to work, on multiple wrappers (both vanilla iexplore.exe and custom app). I've tried various winetricks (gdiplus, all fonts, core fonts, tahoma). 

The strange thing is that anti-aliasing is working on the same app in Play-on-Mac using wine 1.4rc4. So, I tried comparing the registries of the Play-on-Mac version and the Wineskin wrapper. There were some differences in font locations... but no changes made a difference.

Could it have something to do with X11? Play-on-Mac uses an external X11 (I'm using Apple's version, not XQuartz), while Wineskin uses a custom X11 instance. Maybe a clue?



Its possible its something to do with WineskinX11, but I'm not sure what it would be.  99% of WineskinX11 is unmodified XQuartz code... only minot modifications are made and none of them should even affect Fonts.

is this only in iExplore for you?  Did you turn on Fontsmooth=gray in Winetricks?  I can use several programs (even notepad) and blow the font up large and enable and disable font smothing and see the difference easily.



Can be a wine bug...



Still no luck. Tried Fontsmooth=gray (I was using RGB and the others), and reinstalled all-fonts.

I tried it with Notepad and it's hard to tell, but the larger font sizes might be getting anti-aliased.

Could there be an issue with minimum font-sizes? Any other ideas? 



There is a minimum Font size depending on the font being used.  I'm not sure if there is currently a way to set this yourself with Wine.

http://bugs.winehq.org/show_bug.cgi?id=29240(external link)



Could you disable this "feature" in the next release of the Wine engine?... or make it an option? Perhaps this is what PlayOnMac and CrossOver are doing?

 



I cannot tell that they run any differently on my machine... normal Wine command line seems to run the same for me as well... I'm not sure what I'd make it do differently.


Post new message

Attach file Maximum size: 10.00 Mb
Post new reply

Show posts: