Loading...
 

Wineskin News

RSS feed
Published by doh123 on 2011-10-18

I just pushed out a Wineskin 2.5.2 version, and I thought I'd actually tell people the changes... since I haven't since 2.5 came out... its very minor changes

2.5.1 fixed a single permissions problem to fix Winetricks breaking when it needed to use cabextract

2.5.2 fixes .Xmodmap not being linked correctly when launching, so that you should be able to make a .Xmodmap file in Frameworks now and have it work.

2.5.2 also changes libGL (the OpenGL library being used) back to an older more stable version.  The newer one was causing problems with several games, while this older one is much more stable and dependable, and I've noticed no speed loss using it over the newer one.

Published by doh123 on 2011-10-16

WS8Wine1.3.26 through WS8Wine1.3.30 have been re-uploaded.  The new versions will work again with Mac OS X 10.5+ without crashing, while the old versions would only work on Mac OS X 10.6+

You can delete the old versions in Wineskin Winery and download the new versions if you need Mac OS X 10.5 support, or you are making/updating wrappers that you share with others that you want to make sure will run the same on Mac OS X 10.5 and not just 10.6 and 10.7.

Published by doh123 on 2011-10-07

I have went ahead and released Wineskin 2.5, as it seems to be running really good and Beta has gone on long enough.  If you update Wineskin Winery to 1.3 (manually or from the built in updater) you should then get the option to get Wineskin 2.5, as well as WS8 engines and be able to convert WS7 engines to WS8.

WS7 engines will no longer work with 2.5, you must use WS8 engines.

Wineskin 2.0 - 2.4 wrappers will update to Wineskin 2.5, but you must run the Update in Wineskin.app two times!

The Manual and FAQ have been updated (mostly).

Have fun with it, and report any bugs ASAP!

Main Changes since 2.4 (in no specific order)

  • Wineskin internal user folders should always use English words now, so folder linking and such will always work on any language/locale and when ports/wrappers change between languages/locales.  Older wrappers may not update 100% right, and require a 'Rebuild Wrapper' to take advantage of this.
  • Wineskin wrappers will no longer prevent other users from using Wineskin wrappers on the system.  If a pre-2.5 one was run, it will still break them running for other users until you reboot, or remove the /tmp/Wineskin symlink.
  • Custom Commands now run after setting of main variables like wineprefix.
  • Command Line Shell button added to Wineskin.app to get a command prompt for running any tools you need, like regsrv32
  • Wineskin will clean up a bit better after WineskinX11, to prevent problems with crashes when running Xquartz later.  If Xquartz crashes after a Wineskin wrapper has run, the /tmp/.X11-unix folder needs to be deleted and it will work, or just reboot.
  • Extension window adding and editing fixed to display better and correctly when it comes to quotes and backslashes.
  • Option to emulate 3 button mouse added to Wineskin.app Options. It used to always be on.  This will allow fixes to games that Alt+Click in game didn't work, like Diablo 2.
  • Several additions and changes to support WS8 based engines
  • WineskinEngine.bundle is no more... everything is in Contents/Frameworks
  • WineskinX11 is now part of the wrapper and will be updated/changed with wrapper versions, and is no longer part of the engine.  This means updates to engines bases will be ultra rare, as they will mainly just be a Wine build and nothing more.
  • Wineskin 2.5 is using xorg-server 1.11.1 build for WineskinX11
  • WS8 Engines are Wine versions that should keep 10.5+ compatibility
  • WS7 engines are not compatible directly with Wineskin 2.5, however Wineskin Winery 1.3+ will offer to convert your WS7 engines to WS8 engines when it starts up.  This will save you from having to download new engines for the same old Wine versions.
  • Option in Wineskin.app to have all but 1 CPU Core disabled while running.  This will affect your whole system, but some old games only work right with 1 CPU.
  • Update Wrapper fixed to work with new structure.  If you are trying to update a 2.0 to 2.4 wrapper, you need to do an update, then do the update again and tell it to Force the update when asked.
  • There is a WineskinMenuScripts folder in the wrapper with a help.txt file explaining about how to set them up.  This allows you to add custom menu entires to the top drop down menus of a running wrapper.
  • Major overhaul to the Winetricks interface done by Syao (Thanks Syao!).  Can search for packages, do multiple packages, do custom runs, and all types of great things now.
  • Will prompt an error message if you try to run a wrapper from a Read-Only volume.
  • Decorate windows will be on by default now.  Many fullscreen games that didn't work with this option will now work.  For some you may still need to try disabling it.
Published by doh123 on 2011-10-06

Wineskin 2.5 beta has gone through many updates and bug fixes, and the current beta versions available seem to be rather stable and can do everything at least as good as 2.4, if not better.

I'm keeping it beta for maybe another day... or two... unless I get some major problems in Feedback.

If you have not tried it, you may want to, and report back any problems.  I need to only know problems if it is something that worked with the same Wine version in Wineskin 2.4, that now does not in 2.5.  If it didn't work in 2.4 and still doesn't in 2.5, that will have to be addressed in a later update, as at this point we just need to get 2.5 finalized and available for use.

You can still get a beta build of Winery to test all of this here...

Click Here to download the Beta Wineskin Winery build, which will let you get WS8 Engines and Wineskin 2.5!!

Published by doh123 on 2011-10-05

As most people probably know, Steve Jobs died today.  May our prayers be with him and his family... and may Apple continue in its success in the future.

http://www.apple.com/stevejobs/

Published by doh123 on 2011-09-29

Beta testing has been going a long good... finding a lot of bugs and other problems and getting them fixed.

Current wrapper version up is Wineskin-2.5g

This one should have the final xorg-server 1.11.1 WineskinX11 version finalized (I hope).  I finally found and squashed all the bugs I know about.

And a BIG thanks to Syao, who has overhauled the Winetricks interface into something much more powerful, with all sorts of options!  There is still some tweaking to do, but the majority of it is already in 2.5g.

  • Allows the user to select multiple packages at once for installation
  • Shows the description next to the package name
  • Adds a search bar to filter the shown packages
  • Shows which packages are already installed in the wrapper
  • Shows which packages are already downloaded to the user's Caches folder
  • Allows the user to specify a custom winetricks command line
  • Note: First startup of the winetricks UI may be slow, since it generates the installed and downloaded packages lists
  • Note: the installed packages list is cached inside the wrapper
  • Note: the downloaded packages list is cached in the user's Caches directory, together with the winetricks packages cache (so that when the cache is wiped, the list is also wiped)
  • Note: Keeping the Downloaded and Installed lists are Optional (Default disabled).  If you enable them, except longer load times after installing packages as these lists have to be updated, and its not an exetremely fast process.

 

  Known Issues I am still going to work on... Please report any problems that are not on this list ASAP... want to get 2.5 out of beta soon  :-)
  • quartz-wm (window decorations) may have problems working correctly if a space is in the name of the wrapper in 2.5g.  This will be fixed for next version, was a simple oversight
  • Still various multi-user problems on the same system I'm working on
  • Still various issues for non-admin users when using a wrapper that was made by an admin user on the same system
  • Engines in Wineskin.app Change Engine list are in an odd order, and not ordered nicely like Wineskin Winery now does
  • Still need some further testing on 10.5 and Wine version issues on 10.5 not being able to run.
Published by doh123 on 2011-09-23

Since Wineskin 2.5 update with WS8 engines are bringing a major change to Wineskin, I thought it was best to run a bit of a Beta first to make sure all the bugs are squashed.

Please Report Bugs ASAP as a response to this post, or to the Support Forum indicating its the Wineskin 2.5 Beta!

Here are a list of the major changes currently in...

Wineskin Winery Changes

  • Updated for Wineskin 2.5 and WS8 engine changes. Wineskin Winery no longer supports using WS7 and older engines, due to the engine changes in WS8, sorry. Stick with an old version if you want to use old engines and old wrappers, but I see no point in that.
  • Will prompt at start up and after wrapper updates to convert WS5 - WS7 engines to WS8, if you have Wrapper 2.5+ installed.  The conversion can take a long time for many engines, but may be better than downloading new versions.
  • Engine build lets you choose an OS version to build for.  This lets you easily select 10.6 so you can do builds with Xcode 4, but the engines will not run on 10.5 like standard engines.Here is a download link.

Wineskin Changes

  • Wineskin internal user folders should always use English words now, so folder linking and such will always work on any language/locale and when ports/wrappers change between languages/locales.  Older wrappers may not update 100% right, and require a 'Rebuild Wrapper' to take advantage of this.
  • Wineskin wrappers will no longer prevent other users from using Wineskin wrappers on the system.  If a pre-2.5 one was run, it will still break them running for other users until you reboot, or remove the /tmp/Wineskin symlink.
  • Custom Commands now run after setting of main variables like wineprefix.
  • Command Line Shell button added to Wineskin.app to get a command prompt for running any tools you need, like regsrv32
  • Wineskin will clean up a bit better after WineskinX11, to prevent problems with crashes when running Xquartz later.  If Xquartz crashes after a Wineskin wrapper has run, the /tmp/.X11-unix folder needs to be deleted and it will work, or just reboot.
  • Extension window adding and editing fixed to display better and correctly when it comes to quotes and backslashes.
  • Option to emulate 3 button mouse added to Wineskin.app Options. It used to always be on.  This will allow fixes to games that Alt+Click in game didn't work, like Diablo 2.
  • Several additions and changes to support WS8 based engines
  • WineskinEngine.bundle is no more… everything is in Contents/Frameworks
  • WineskinX11 is now part of the wrapper and will be updated/changed with wrapper versions, and is no longer part of the engine.  This means updates to engines will be ultra rare (WS8 will be around a LOOONG time), as they will mainly just be a Wine build and nothing more.
  • WS8 Engines are Wine versions that should keep 10.5+ compatibility (there are still some bugs on the latest versions of Wine and 10.5 that need to be fixed)
  • WS7 engines are not compatible directly with Wineskin 2.5, however Wineskin Winery 1.3+ will offer to convert your WS7 engines to WS8 engines when it starts up.  This will save you from having to download new engines for the same old Wine versions.
  • Option in Wineskin.app to have all but 1 CPU Core disabled while running.  This will affect your whole system, but some old games only work right with 1 CPU.
  • Update Wrapper fixed to work with new structure.  If you are trying to update a 2.0 to 2.4 wrapper to a 2.5 wrapper, you need to do an update, then do the update again and tell it to Force the update when asked, then you need to Change Engine to a WS8, then you need to manually remove the WineskinEngine.bundle and it should work.
  • There is a WineskinMenuScripts folder in the wrapper with a help.txt file explaining about how to set them up.  This allows you to add custom menu entires to the top drop down menus of a running wrapper.

Be careful if you use the function to Convert WS7 to WS8 engines, because its a 1 way process... and if you want to currently go back to non-Beta you'll have to download your WS7 engines again.  Hopefully you won't need to, because I think Wineskin 2.5 is great so far!

Click Here to download the Beta Wineskin Winery build, which will let you get WS8 Engines and Wineskin 2.5!!

Published by doh123 on 2011-09-19

I've done some major redesigning of how Wineskin wrappers are set up... which will be available with Wineskin 2.5 and WS8 engines.  I'll point out the main differences, and would like any and all feedback, complaints, and ideas!

WineskinX11 is no longer part of the engines, it has been moved to be part of the wrapper.  This allows an easy way to update it and fix problems or bring new enhancments without having to upgrade a whole engine base and remake every engine version with the new base.

WS8 based Engines will be 10.5+ compatible still, but internally they will ONLY contain Wine... so they are basically just a Wine build.

To not have to download WS8 engines if you have WS7, I'm going to put in a converter in Wineskin Winery so it will auto convert your WS7 engines to WS8 if you tell it to. (this is pretty much the only part I do not have done and working in alpha builds)

The WineskinEngine.bundle in the Resources folder of the wrapper is no more... X11 files are stored in Contents/Frameworks where Apple guidelines says things like this should be.  There will also be 1 bundle kept in there too called wswine.bundle which will contain Wine from your selected engine.

I'm thinking about also changing the term "Engine" to just Wine version...? thoughts?  My problem is that in the future we may start building them to be 10.6+ or whatever and no longer support 10.5, so I thought keeping them engines with WS8 or WS9 lets it quickly inidicate there is a difference and not just a free-for-all Wine version. Wineskin Wine Version sounds a bit weird, when Wineskin Engine Version sounds a bit better to me... plus its already whats in use.

Wineskin 2.5 and WS8 will have a beta, which will be manually installers you download and install into Wineskin Winery.  You'll always be able to revert back to 2.4 in Winery by hitting its Update button, since that only looks for the newest released version.

Published by doh123 on 2011-09-17

Just a couple of small updates, but getting in gear for a Wineskin 2.5 update and WS8 engines soon, so thought I'd get the Winery bugs fixed and pushed out.

  • Downloaded Engines, and Engines you ignore will never prompt as new again
  • If your downloaded engine is corrupted, Wineskin Winery will prompt you instead of trying to build and making a broken wrapper.

Have fun!

Published by doh123 on 2011-09-09

Wine 1.3.28 was released at WineHQ.org today, so here is an engine that uses it!

You should see it as available so you can download it through Wineskin Winery, or the manual download location.

 

Link to Wine 1.3.28 Release Notes

 

There is currently still a bug with Mac OS X 10.5 running.  As of now the following engines will not run on Mac OS X 10.5, only on 10.6 and 10.7.  No known ETA on a fix.

WS7Wine1.3.26

WS7Wine1.3.27

WS7Wine1.3.28 (this one)

 

Sorry about that 10.5 users!

 

Have Fun!

First PagePage: 7/9Last Page
156789